Midland 98 plus no speaker sound

General CB Radio Advice and Troubleshooting

Moderator: stampman

Post Reply
Biggy88
New to the Scene
New to the Scene
Posts: 3
Joined: Tue Mar 15, 2016 1:30 pm

Wed Mar 29, 2017 1:03 pm

I wonder if anyone can help. I have a Midland 98 plus cb and there is no speaker sound and squelch is on. I have ran wires across the pins but still no sound. The rig still operates as it should but just cannot work out what issue could be besides it may require a new speaker or possibly a new amp being fitted.

Any help or advice would very much appreciated.

User avatar
andy@thunderpole.co.uk
Site Admin
Posts: 1040
Joined: Tue Mar 14, 2006 4:53 pm
Location: Northampton
Contact:

Thu Mar 30, 2017 9:26 am

Could be the internal speaker, easiest way to find out is plug an extension speaker in to see what happens.

Andy :wink:

fazer
New to the Scene
New to the Scene
Posts: 7
Joined: Wed Sep 19, 2018 10:31 pm

Sat Jan 19, 2019 12:33 am

I have the same problem, no receive, bit of a strange low were-ring noise with an extension speaker plugged in, it transmits ok.

User avatar
stampman
- - -> CB God <- - -
- - -> CB God <- - -
Posts: 6070
Joined: Mon Apr 24, 2006 3:36 pm
Location: lancaster

Sat Jan 19, 2019 10:56 am

sounds like a voltage overdrive

*King* *King* *King* *King*
if it anit broke dont fix it

Cactusjack1879
New to the Scene
New to the Scene
Posts: 2
Joined: Fri Jan 18, 2019 4:42 pm

Wed Feb 13, 2019 11:04 am

I’ve got the same problem on my (other company) minor. It works ok on external speaker. I put an ohm meter across the speaker terminals and no reading so it’s broken. Does anyone know where to get a replacement speaker? I bought a small one but it was still too big to fit in the tiny (other company).

Post Reply