Transistor Testing Help please???

General CB Radio Advice and Troubleshooting

Moderator: stampman

Post Reply
woodbine
New to the Scene
New to the Scene
Posts: 5
Joined: Sat Jul 30, 2016 9:17 pm

Sat Jul 30, 2016 9:48 pm

Model Number: REALISTIC TRC-2001 TRANSISTOR PROBLEM
Board Number: PA-034AA
Problem: FAULTY TRANSISTOR

OK so I am a CB newbie and please bare with me. I am learning electronics and know the basics - enough to get by with building my own little circuits etc. At first I wanted to learn about radios and their operations so I decided to take on the hobby of CB radios, as-well as building a few basic radio circuits to transmit and receive signals and get an understanding.

Today I got given a "Realistic TRC-2001" Transciever. No power supply, No Microphone, Not working, No cost! Perfect project.

Power supply is sorted I have one that is sufficient and powers another thing he gave me - a scanner. Voltage is the same. The mic is a 5 pin DIN, about £20 to buy - so Im not worried about them. The problem is it doesnt turn on and a component needs replacing.

The guy who gave it to me is a HUGE enthusiast, been doing it for years since and during his military years but to help me learn he said this......" I know what is wrong with it, I could fix it, I even have the part, but I'm not going to tell you what to do - you have to figure it out". If I do fix it he will give me a load of other goodies he has spare, antennas and accessories. But I want it working to get using it.

HE GAVE ME A CLUE.....It has 3 pins, it is black, and it costs about £7.00

So I'm looking at the circuitry and there are a few Transistors in there. 3 pins, black. I have used a similar looking transistor called an n2222a dor an electronics project. BUT I have no idea how to test these reliably without having to desolder every one. They start at TR1 and go up to as far as I can see to TR19.

There is NO schematic for this board or CB online as far as I can see, there's a LOT of realistic model 'walkie talkie' (sorry) type radio sets, I did find a user manual, however the manual was for both the TRC-2000 and the TRC-2001 (mine) the schematic included read: ONLY FOR TRC-2000 - I checked the images of the 2000 model and it is a bit different.

How do I test the transistors with a multimeter??

I read about doing it with OHMs setting but there are so many types and variants I wouldn't know what to look for. A guy on you-tube had a radioshack component tester....easy but I dont have that luxury.

I thought about doing this: get a pen and paper. Write a list - TR1, TR2, TR3......etc then write each part number next to each part and go from there. If I know what to test for I can tick off each one as I go


NOTE....I have looked at a few of the transistors part numbers and they are all pretty cheap to buy, theres NONe that are £7.00 pricerange. I did see a few on the board that I havent come across (looks wise) and they were like elongated transistors - like a NPN type but taller in body.

Any suggestions to get this old CB radio working Please let me know I would be very grateful.

I don't want to buy one, its all about learning for me so please no funny comments like 'bin it and buy one that works'

Thanks Ben

woodbine
New to the Scene
New to the Scene
Posts: 5
Joined: Sat Jul 30, 2016 9:17 pm

Sat Jul 30, 2016 11:15 pm

OK so I have done a little further research and I may have been looking at the wrong type of transistors....

There are the little black 3 pinned ones, but there are also 2 bigger transistors (they look like a LM317 voltage regulator)

So the 2 of these are a Power transistor....and an Audio Amp Driver

The Power Transistor costs £6.50 each which is close to my riddle like clue to fixing this circuit.

The part numbers are.....:

C2028/2 (Audio Amp Driver) also written C2028(2)
C2029/1 (Power Transistor) also written C2029(1)

Now...I looked for some info on a replacement part for this power transistor. I couldn't find the exact one, BUT a search came up with an exact replacement for the part...an equivalent was:

NTE235 Silicon Transistor (RF)
65V / IC=3A / TO-220 / PO=5W / 50 MHz

So it sounds ok with the output wattage being around the same, although the 65V seems a little high with it running on 13.2 Volts. I am unable to find a Data Sheet for the original part so I cannot compare. Do I trust this parts site's judgement on an equivalent?

I don't know how to test this component tough of all the parts on the board... and based on my clues I'm quite sure this is the part to replace.

Dragonfly
Motor Mouth!
Motor Mouth!
Posts: 436
Joined: Thu Oct 07, 2010 3:11 pm

Sun Jul 31, 2016 8:21 pm

If the radio dose not light up at all then check the fuse first then the protection diode { 1N4004 ) , If that checks out ok then check the on off switch is passing current through , If that checks out ok find the voltage regulators and check for input 13v and output 8v .
The 4wat output transistor C2029 was replaced by 2SC2078 .

Edit Check TR19 has 12.5 v in and 8,8v out . http://www.cbtricks.com/radios/uniace/1 ... 00_sch.pdf

Post Reply