User issue midland 98 plus

Place to come if youre having technical issues, including mic wiring

Moderator: stampman

Post Reply
Bigman1207
New to the Scene
New to the Scene
Posts: 8
Joined: Sat Sep 03, 2016 7:00 pm

Sun Sep 04, 2016 9:05 am

I don't think my rig is broken more a lack of user manual so I will describe the issue . . . .

When I switch radio on I get three beeps volume up full squelch turned to minimum I get no noise

It also if I keep squelch button pressed makes another beep esl I have no idea what this is or does

Sometimes say fifty percent of the time I get noise ap per normal when the squelch is turned down

Aerial and mic connection checked where the screw in and seem okay

So my operating fault or rig fault?

Oh it's wired via cig lighter in a van

Cheers

Bm

Bigman1207
New to the Scene
New to the Scene
Posts: 8
Joined: Sat Sep 03, 2016 7:00 pm

Sun Sep 04, 2016 12:46 pm

It's got esp not what I said above! Sorry

Dragonfly
Motor Mouth!
Motor Mouth!
Posts: 436
Joined: Thu Oct 07, 2010 3:11 pm

Mon Sep 05, 2016 12:35 am

Sounds like the recieve wire has broken tn the mic plug .
Attachments
25042013297 (2).jpg
25042013297 (2).jpg (589.13 KiB) Viewed 2592 times

Bigman1207
New to the Scene
New to the Scene
Posts: 8
Joined: Sat Sep 03, 2016 7:00 pm

Mon Sep 05, 2016 9:10 am

Brilliant thank you for the reply will have a look later today many thanks

Bigman1207
New to the Scene
New to the Scene
Posts: 8
Joined: Sat Sep 03, 2016 7:00 pm

Mon Sep 05, 2016 10:12 am

All wires in mic plug are connecter amd also in the mic itself wires are different colours though to the diagram

Cheers bm

Bigman1207
New to the Scene
New to the Scene
Posts: 8
Joined: Sat Sep 03, 2016 7:00 pm

Mon Sep 05, 2016 12:04 pm

All put back together same as previously not had noise for quite some time now on.matter how many times I switch on or off

Bigman1207
New to the Scene
New to the Scene
Posts: 8
Joined: Sat Sep 03, 2016 7:00 pm

Mon Sep 05, 2016 12:05 pm

Is there a way to check by bridging pins on the cb with Mike removed?

Bigman1207
New to the Scene
New to the Scene
Posts: 8
Joined: Sat Sep 03, 2016 7:00 pm

Mon Sep 05, 2016 12:24 pm

Google search

Okay bridged pins c and r on full volume got a very very slight buzz only just audible


Any ideas?

User avatar
andy@thunderpole.co.uk
Site Admin
Posts: 1031
Joined: Tue Mar 14, 2006 4:53 pm
Location: Northampton
Contact:

Mon Sep 05, 2016 1:37 pm

Could be a faulty squelch control, or could be adjusted incorrectly inside the unit.

Andy :wink:

Post Reply