Poor reception on auto power jd 6920s

Agricultural vehicle CB Radio advice and troubleshooting

Moderator: stampman

Post Reply
creekie82
New to the Scene
New to the Scene
Posts: 6
Joined: Wed Apr 08, 2009 12:11 pm

Wed Apr 08, 2009 12:36 pm

I drive a jd 6920s auto power, I,m using a Sirio Hi power 4000 Antenna with a Team Roadcom Cb. Its a fixed mounting in the middle if the roof bollted down by the two main bolts. I don't think i'm have a problem with putting out as folk have told me they can hear me no prob its the receiving that seems to be the problem. I seem to get a reasonable reception with the tractor off and not to bad when its ticking over but as soon as I rev the bars on CB go right up and can't hear anybody even in the next field. I had a noise reducer fitted at one time which didn't seem to make any diff . Has anybody come across this prob or anything similar?
Any ideas on the cure for this problem? I,m convinced it has something to do with the gear box as a few other auto power drivers don't seem to get great reception either. All the kit was fitted from new so wasn't really thinking there was a problem there unless a simpler CB could possibly help not pick up the interference.
Any help much appreciated

User avatar
stampman
- - -> CB God <- - -
- - -> CB God <- - -
Posts: 6054
Joined: Mon Apr 24, 2006 3:36 pm
Location: lancaster

Wed Apr 08, 2009 4:35 pm

sounds like it could be a bad earth or an altinator problem does it go up when you just rev the engine if so could be the altinator which will give you a whine on the rx as well

:D :D :D :D *King* *King* *King*
if it anit broke dont fix it

creekie82
New to the Scene
New to the Scene
Posts: 6
Joined: Wed Apr 08, 2009 12:11 pm

Wed Apr 08, 2009 9:05 pm

Thanks for quick reply stampman. Start it up and a couple bars come up but stay quite low then rev and I get full bars when it goes back to idle the bars stay at full. Any ideas on how to tackle these problems. Also what do you think of this rig I was led to believe it should be quite reasonble.
Thanks

User avatar
stampman
- - -> CB God <- - -
- - -> CB God <- - -
Posts: 6054
Joined: Mon Apr 24, 2006 3:36 pm
Location: lancaster

Thu Apr 09, 2009 8:37 am

sounds like altinator you need to fit suppressors to it try a good car radio shop for them road com seem to be ok


:D :D :D :D *King* *King* *King*
if it anit broke dont fix it

creekie82
New to the Scene
New to the Scene
Posts: 6
Joined: Wed Apr 08, 2009 12:11 pm

Thu Apr 09, 2009 8:53 am

Just tried it with the fan belt of there and it seems to have a few less bars on the CB but stll be sitting half way. I don't think it would be the earth as i'm sure most of these tractors are fitted from this point

User avatar
stampman
- - -> CB God <- - -
- - -> CB God <- - -
Posts: 6054
Joined: Mon Apr 24, 2006 3:36 pm
Location: lancaster

Thu Apr 09, 2009 10:08 am

iff it drops with the fanbelt off then it is giving interferance and you need suppression before you can look further for the rest of the interferance


:D :D :D :D *King* *King* *King*
if it anit broke dont fix it

creekie82
New to the Scene
New to the Scene
Posts: 6
Joined: Wed Apr 08, 2009 12:11 pm

Thu Apr 09, 2009 5:25 pm

When I had the fan belt off I got my mate on neighbouring Farm to give me a shout and I was well happy with the reception I was getting! Put belt back on went and picked up a suppressor today put it on and got him to give me a shout again. Wasn't near as good this time better than what I started off with but not near as good as fan belt off. May need to extend the wire on the suppressor to get to a better earth and try that.

User avatar
stampman
- - -> CB God <- - -
- - -> CB God <- - -
Posts: 6054
Joined: Mon Apr 24, 2006 3:36 pm
Location: lancaster

Fri Apr 10, 2009 10:36 am

no see if you can get a differant value for the suppressor prefrably a higher value one or try double ing the up ie try with 2 on


:D :D :D *King* *King* *King*
if it anit broke dont fix it

creekie82
New to the Scene
New to the Scene
Posts: 6
Joined: Wed Apr 08, 2009 12:11 pm

Sat May 09, 2009 9:38 am

Thats me now got 2 suppressors fitted and haven't noticed a big difference to just having the one fitted should I be adding more or is this not going to help?

User avatar
stampman
- - -> CB God <- - -
- - -> CB God <- - -
Posts: 6054
Joined: Mon Apr 24, 2006 3:36 pm
Location: lancaster

Sat May 09, 2009 12:21 pm

sounds like the wrong value of suppressor been supplied they have given you one for the national broadcasting stations you need one for cb differant value i think ring mobile radio at preston lancs and ask for bob dont think this breakes the rules as they do not sell cb parts andy ok ring me if im wrong

:D :D :D :D *King* *King*
if it anit broke dont fix it

Post Reply